Код ответа сервера HTTP — это трехзначный номер, который сообщает браузеру о том, как завершился запрос к странице сайта. Коды ответа сервера делятся на пять классов: информационные, успешные, редиректы, ошибки со стороны клиента и ошибки со стороны сервера.
Наиболее известными кодами ответа сервера HTTP являются:
- 404 (Not Found) — страница не найдена.
- 200 (OK) — запрос выполнен успешно.
- 500 (Internal Server Error) — внутренняя ошибка сервера.
- 301 (Moved Permanently) — страница перемещена на другой адрес.
Коды ответа сервера HTTP важны для поисковой оптимизации, поскольку влияют на то, как страницы сайта будут отображаться в результатах поиска.
- Информационные коды (100 — 199) сообщают браузеру, что запрос получен и обрабатывается.
- Успешные коды (200 — 299) указывают, что запрос выполнен успешно.
- Перенаправления (300 — 399) сообщают браузеру, что для выполнения запроса необходимо перейти на другой адрес.
- Клиентские ошибки (400 — 499) указывают, что в запросе был обнаружена ошибка.
- Серверные ошибки (500 — 599) указывают, что на стороне сервера произошла ошибка
Описание: Проявляется, в случае некорректного запроса. Следовательно, причину данной ошибки стоить искать на стороне конкретного клиента:
Решение: Вам скорее всего поможет одно из решений:
- проверьте корректность запрошенного адреса страницы на соответствие регистра вводимых символов. Что это значит? Давайте разберёмся, на пример example.com и Example.COM это два разных названия с разным регистром символов, к стати не забудьте проверить и спецсимволы такие как % & / и т.д.
- Очистите браузерный кеш и куки, попробуйте перелогиниться на сайте.
Если же ошибка проявляется систематически, то:
- Попробуйте откатить последние изменения в коде вашей системы, к состоянию до появления ошибки
- Удалить/отключить недавно установленные расширения и плагины последнего работоспособного состояния
Описание: Данная ошибка 405 Not Allowed возникает из-за работы php скрипта, пытающегося провести некорректный POST запрос, который в результате получает отказ в обработке со стороны сервера.
Решение: Для того что бы найти причину ошибки, нужно воспользоваться логами. Если вы столкнулись с этой ошибкой, то попробуйте увеличить параметры в php:
- max_execution_time
- memory_limit
- post_max_size
- upload_max_filesize
Описание: Возникает в том случае, если запрос содержит признаки попытки использования уязвимостей в популярных CMS для получения несанкционированного доступа к управлению сайтом.
Решение: Если вы видите в логе сайта эту ошибку то не стоит волноваться, это говорит лишь о том, что кто-то пытался сканировать ваш сайт на наличие уязвимостей и мы не позволили это сделать. Узнать больше о данной ошибки, можно используя логи в панели управления.
Описание: Ошибка свидетельствует о том, что серверу не удается обработать запрос. Как правило, подобная ошибка возникает из-за некорректной конфигурации файла .htaccess. Так же, данная ошибка, может возникнуть из-за ошибки работы PHP скриптов.
Решение: Нужно проверить права на файлы и каталоги:
- Не рекомендуется устанавливать права на файлы выше 644 и 755 для каталогов, так как это может привести к ошибке 500
- Комментарии в конце строки
- Не корректные комментарии к строкам в файле .htaccess
- BOM-символы
- В .htaccess при редактировании быть записаны невидимые BOM-символы, из-за которых и возникает ошибка. Для устранения проблемы следует открыть файл в каком-либо редакторе, и сохранить его в чистой кодировке UTF-8 и загрузить обратно на хостинг
Описание: Это ошибка временного характера, которая возникает в случаях, когда сайт поддается нагрузке, которая превышает установленные лимиты — т.е. сервер временно прекращает обработку поступающих запросов и становиться временно не доступным. В некоторых случаях (когда проблема имеет разовый характер), ошибка решается сама собой и не требует вмешательства со стороны администратора или тех поддержки.
Решение: Однако, если ошибка имеет системный характер и проявляется периодически, вам скорее всего поможет одно из решений:
- Добавьте в ваш robots.txt директиву Crawl-delay что позволит откорректировать интенсивность сканирования страниц сайта поисковыми системами
- Проверьте компоненты своей CMS. Например компоненты, которые не входят в состав системы по умолчанию: это могут быть дополнительные плагины, сторонние сервисы, кастомный функционал и т.д. и т.п.. Попробуйте заменить самые ресурсоемкие из них
- Обязательно оптимизируйте работу своего сайта
Описание: Причиной ошибки 508 является превышение максимального допустимого количества одновременно работающих процессов Apache в хостинг-аккаунте. В случае возникновения ошибки 508 следует проанализировать логи сервера, чтобы определить типы запросов, которые запускали эти процессы. Ошибка часто сопровождается в Error-логе сайта записями вида «LVE enter: LVE(XXX) HANDLER(XXX) HOSTNAME(XXX) URL(XXX) TID(XXX) errno (7) Read more: http://e.cloudlinux.com/MHL-E2BIG min_uid (0)». Распространённые причины проблемы:
- Недостаточная оптимизация скриптов сайта
- Неоптимальная работа сайта с базой данных. Например, наличие медленных запросов или отсутствие индексов
- Неправильная логика работы сайта, из-за чего его он обращается к своим же ресурсам не напрямую, а по HTTP, тем самым порождая лишние запросы
- Скрипты сайта в процессе своей работы обращаются к сторонним ресурсам, причиной может быть недоступность или долгий ответ этих ресурсов
Решение: Для решения проблемы могут применяться ниже следующие способы:
- Анализ логов и его остановка излишних процессов. Если остановить источник невозможно, ограничение доступа к сайту для него.
- Оптимизация потребления ресурсов сервера
- Принудительное завершение активных процессов
- Если самостоятельно определить причину и принять меры возможности нет, следует сообщить о проблеме веб-разработчику сайта
- Если выше перечисленные действия не помогли то возможен вариант перехода на один из больших тарифов на хостинге
В приведенном выше списке поясняется большинство кодов статуса HTTP, с которыми вы можете столкнуться.
Этот список охватывает все пять классов кодов ответа сервера HTTP, а также некоторые из наиболее известных кодов в каждом классе.
Конечно, в Интернете существует множество других кодов состояния HTTP, которые могут быть использованы для более специфических целей.
Например, код ответа 429 (Too Many Requests) указывает на то, что сервер получил слишком много запросов от одного клиента.
Если вы столкнулись с кодом состояния HTTP, который не объясняется в приведенном выше списке, вы можете найти дополнительную информацию на веб-сайте HTTP Status Codes