Как исправить 500 ошибку на сайте под управлением CMS WordPress?
Белый экран с надписью 500 Internal Server Error это самая часто встречающаяся неполадка с которой многие сталкиваются. Причем устранение данной неполадки, достаточно сложное и трудоёмкое занятие. Причина этому является сложность в поиске повреждения, которое может иметь обширный перечень факторов. Явными причинами возникновения этой неполадки, в основном служат неаккуратные действия владельца. Поэтому важным аспектом быстрого решения проблемы, будет воспроизведение действий. Которые вы делали перед образованием данной проблемы. Благодаря этому, вы быстрее поймете причину критической неполадки. Давайте пройдёмся по основным факторам возникновения данной ошибки:
Содержание статьи:
- Причина возникновения 500 Internal Server Error
- Как исправить и восстановить работоспособность сайта
- Обновление CMS прошло неудачно и привело к непредвиденной ситуации
- Возможный конфликт между плагинами в самой админ панели
- Ситуация в WordPress связанная с шаблоном установленной темы
- Неграмотное внесение изменений в серверные правила
- Непредвиденные или неправильные изменения functions.php или wp-config.php
- Нехватка серверных ресурсов — к примеру памяти
- Неправильная версия php способствует этой ситуации
Причина возникновения 500 Internal Server Error
Факторов должным образом вызывающих эту непредвиденную ситуацию, может быть огромное количество. Стоит отметить, что в большинстве случаев 70% из 100%, виновником становиться сам администратор или вебмастер. Внося изменения в конфигурацию или директории и т.д. Буквально пропустив точку с запятой, особенно при редактировании правил для серверной части. Вам сразу свалится на голову эта проблемка. Давайте рассмотрим еще факторы:
Неудачное обновление движка WordPress.
- Конфликт между плагинами и новым установленным плагином.
- Плохой шаблон темы или неудачное обновление установленной темы.
- Неправильное правило указанное в .htaccess или пропуск точки с запятой.
- Неграмотное внесение корректировок в WP или в самом шаблоне темы.
- Пропустили точку с запятой, внесли критические изменения или удалили важную строку кода. Нехватка серверных ресурсов необходимых для стабильной работы.
- Недопустимая версия php указанная на сервере или хостинге.
Были перечислены основные и наиболее распространенные факторы, под силу которым способствовать этой неприятности.
Как исправить и восстановить работоспособность сайта
Исправление этой неполадки возможно в большей степени если у вас хорошая память. Ваша задача вспомнить те действия, после выполнения которых вы получили критическое уведомление. Далее следует вернуться и исправить соответствующий код. В большинстве случаев этот метод помогает, я очень часто сталкивался с этой неполадкой во время редактирования конфигурационных файлов WP и .htaccess. Давайте рассмотрим все варианты.
Обновление CMS WordPress прошло неудачно и привело к непредвиденной ошибке 500
Обычно при обновлении системы управления контентом подобных неприятностей нет. При этом стоит учитывать рекомендации разработчиков CMS, которые уведомляют каждого владельца перед проведением обновления. О том, что необходимо выполнить резервное копирование для проведения благополучного обновления. Если вы внимательны и делаете резервные копии проекта, то проблем с восстановлением WP у Вас не возникнет. Несколько решений: Это возможно костыль, но действенный, выполните скачивание дистрибутива движка. Затем подмените все файлы в папке проекта на новые. Также в случае неудачного обновления, можно попробовать переустановить обновление в админке. Только в том случае, если она будет доступна. Можно просто переместить или переименовать названия плагинов. Причина может крыться именно в них. Если сайт заработал, подключите последовательно все установленные плагины, таким образом вы определите уязвимость и устраните неполадку.
Internal Server Error в WordPress — причина конфликт между плагинами
Важно понимать, когда вы получаете фатальную ошибку, доступность сайта сходит на ноль. Также это касается и админки WP. Поэтому решать конфликты плагинов в WP или неудачного обновления злополучного плагина, придется на стороне сервера или хостинга. В таком случае правильным будет подключение к серверу или хостингу через файловый менеджер или используя для подключения ftp клиент. Пара примеров: Подключитесь к сайту воспользовавшись ftp , зайдите в директорию «plugins» на сайте. Определите конфликтный плагин и поменяйте его название. Затем обновите страницу проекта, ошибка должна исчезнуть. Если пример выше не дал определенных результатов, в таком случае удалите плагин полностью. Бывает так, многие начинающие владельцы любят устанавливать много и сразу. Чтобы не терять свое драгоценное время, такой метод убьет Ваше время в конец. Действия практически идентичны верхним, только в этом случае придется переименовывать все что вы установили. Вы также можете создать другую директорию с отличающимся названием и выполнить перенос.
Фатальная ошибка в WordPress связанная с шаблоном используемой темы
Если в этом случаи нет доступа к админки WP то вам следует осознать, что в дальнейшем использование этого брака, будет являться нецелесообразным и даже глупым решением. Которое будет приводить к более серьезным конфликтам. Как решить эту проблему: Подключитесь к сайту воспользовавшись:
а) FTP клиентом или файловым менеджером, потом следует зайти в папку сайта, папку wp-content и в папку themes и удалить неисправный шаблон только в том случае если у вас есть еще одна тема. Если же её нет то сначала закачайте тему а потом разархивируйте её. В WP должна быть одна рабочая тема в любом случаи. В итоге доступ к админки WordPress будет восстановлен. Следующим шагом будет, загрузка и активация работоспособной темы.
б) В панели управления cPanel -Диспетчер фалов- потом следует зайти в папку сайта, папку wp-content и в папку themes и удалить неисправный шаблон только в том случае если у вас есть еще одна тема. Если же её нет то сначала закачайте тему а потом разархивируйте её. В WP должна быть одна рабочая тема в любом случаи. В итоге доступ к админки WordPress будет восстановлен.
Ошибка 500 в .htaccess неграмотное внесение изменений в файл
В этом случае все необходимые операции выполняются только с файлом .htaccess. Самым быстрым решением проблемы будет, воспроизведение Ваших последних действий. Удаление правила, которое не прижилось на сервере. Несколько методов исправления: Самое простое и безболезненное — это удаление самого .htaccess, но это не правильно! Переименовываем .htaccess и создаем новый пустой .htaccess. После этого следует внимательно изучить, копию старого поврежденного файла на наличие ошибок. Допустим ничего странного вы не обнаружили, приступаем к переносу правил последовательно. Важно!!! внося каждое исправление проверять работоспособность проекта, через браузер в режиме инкогнито и с очисткой кеша браузера. Муторно за то на 100/500 работает!
Internal Server Error в functions.php или wp-config.php
Два этих конфигурационных файла, это самые важные. Все изменения в них должны проводиться аккуратно и очень грамотно. Малейшее неграмотное изменение, может привести к очень печальным последствиям. Выявить проблему можно только воспроизведением последних проведенных манипуляций. Подсказки вероятно: Пропущена точка с запятой в конце строки кода. Открываем и проверяем целостность. Код вставлен за пределами функции, тогда заходим и перемещаем. Строка кода указана в недопустимом месте, смотрим и переносим или удаляем. В случае фатальной ошибки с невозможностью найти код в wp-config. Скачивайте архив движка, затем подмените свой wp-config на тот который в архиве. Важно!!! скопировать всю информацию для подключения к базе данных MySql из старого файла в новый. Это касается: имя базы данных, имя пользователя, пароль, имя сервера, кодировка, обязательно префикс. После этого все должно заработать. Если проблема в functions.php и нет возможности для исправления. Значит скачивайте именно архив своего шаблона темы, далее распакуйте. После этого замените свой functions.php на новый из распакованного архива.
500 Internal Server Error в WordPress нехватка серверных ресурсов памяти
Со временем на проект приходит все больше посетителей, количество контента постоянно растет. Все это достаточно серьезно влияет на потребление сайтом ресурсов сервера. И в один прекрасный момент сервер или хостинг больше не могут предоставлять выделение необходимого количества памяти на выполнение процессов. Данная неприятность связана с установленными лимитами на сервере или хостинге. Когда наступает момент исчерпания ресурса на стороне сервера, возникает это последствие. Как изменить лимиты?
- Если вы используете на сервере панель управления VestaCp — увеличение лимита проводится в разделе настройки сервера. Значение указывается в поле memory_limit. Также есть возможность поправить конфигурационный файл php.ini, директива отвечающая за лимит памяти выглядит так: memory_limit = 256.
- Если вы используете панель управления cPanel тогда программное обеспечение в нём Выбор версии PHP(здесь же при необходимости можно и сменить версию ) и там уже Настройки: memory_limit, post_max_size, upload_max_filesize
- Указание лимитов памяти в wp-config — открываем и прокручиваем в низ, далее следует вставить две константы:
define(‘WP_MEMORY_LIMIT’, ‘128M’);
define(‘WP_MAX_MEMORY_LIMIT’, ‘512M’);
- Чтобы изменить лимиты памяти в .htaccess достаточно открыть его и внести правило:
php_value memory_limit 128M
Дополнительный материал: Ошибки при переносе сайта
